Starting the software from CLI

From ECHSA Congenital Database


Under normal circumstances, it is easy to run the software. If the standard way of running doesn't work for you, try this instruction. It gets down to the bone of the software starting issue.

Step 1

Ensure you have Java installed and operative.

  • Go: Start->Run.
  • Type "cmd" and press ENTER. A black window will open.
  • Type:
java -version

You'll see, what version of Java you have (if any). The required version is 1.5 (also referred to as 5.0). Version 1.4 is not good for EACTS Software.

Wrong version of Java: Java 1.4 is too old.
Wrong version of Java: Java 1.4 is too old.
Correct version of Java: Java 1.5.
Correct version of Java: Java 1.5.

If you don't have Java 1.5, please go to http://www.java.com and install Java 1.5. Go to Step 1 to verify.

  • If you have Java 1.4, uninstall it and install Java 1.5. Then go to Step 1.
  • If you have Java 1.5, go to Step 2

Step 2

  • Go to the download page
  • Download the Eacts-7.0.10.jar file.

Step 3

  • Move the file Eacts-7.0.10.jar to the C:\ directory.

Step 4

  • Go: Start->Run
  • Type "cmd" and press ENTER. A black window will open.
  • Type:
c:
cd \
dir
  • If you don't see Eacts-7.0.10.jar on the list, go to the Step 3.
  • If you do see Eacts-7.0.10.jar on the list, go to Step 5.

Step 5

  • Type:
javaw -jar Eacts-7.0.10.jar

The application will start. Your session should look like this:

Launching Eacts-7.0.10.jar in command-line.
Launching Eacts-7.0.10.jar in command-line.

If you can run the software only in this way, write yourself a *.bat file that will allow you to launch the software by double-clicking.

See also